UEAGLE(4) OpenBSD Programmer's Manual UEAGLE(4) NAME ueagle - Analog Devices Eagle ADSL modems SYNOPSIS ueagle* at uhub? port ? DESCRIPTION The ueagle driver provides support for USB ADSL modems based on the Analog Devices Eagle chipset (revision I, II and III). The ueagle driver can only manage a single ATM AAL5 virtual circuit. The segmentation and reassembly (SAR) of ATM cells is done by software. To achieve high rate downstream transfer with fast ADSL connections, the ueagle driver uses USB isochronous pipes instead of standard bulk pipes. To establish a permanent virtual circuit (PVC) with a peer, ueagle must be configured using the route(8) command. A typical invocation is: # route add -iface
-link if:encap.vpi.vci_hi.vci_lo The arguments to ``-link'' are as follows: if Interface name. For example, ``ueagle0''. encap Type of encapsulation to use. Possible types are: AAL5 VCMUX Use hex value 0x1. AAL5 LLC/SNAP Use hex value 0x3. vpi See ISP's recommended setting for this. All values specified in hex. vci_hi vci_lo See ISP's recommended setting for this. All values specified in hex. The VCI is specified as high_order_byte.low_order_byte. For example, a VCI of 35 would be specified as ``0.23''. See also EXAMPLES below.